WordPress „Verbindung wurde unterbrochen.“

In einem unserer aktuellen Projekte gab es bei dem hochladen von Bildern, hauptsächlich aber beim Einfügen von Bildern in eine Seite/Beitrag, folgende Fehlermeldung:

„Verbindung wurde unterbrochen. Speichern wurde deaktiviert, bis die Verbindung wieder hergestellt ist. Wir sichern diesen Beitrag in deinem Browser, nur für den Fall.“

WordPress: Verbindung wurde unterbrochen.

Dieses Problem wurde bislang nur in Zusammenhang mit einem Hosting bei 1und1beobachtet, die genaue Fehlerursache konnten wir aber nicht finden.
WordPress und alle Plugins waren bereites auf dem neuesten Stand, auch die Aktivierung eines Standard-Themes brachte keine Abhilfe.

Nach vielem Probieren und Einstellen haben wir letztendlich rausgefunden, dass eine Deaktivierung des Plugins cforms II den Fehler beseitigte.
Warum genau ist noch unklar, eventuell hängt es mit dem cforms-Button im WordPress Editor zusammen.

cforms II ist ein sehr häufig genutztes Plugin. Wir empfehlen, ein alternatives Plugin zu nutzen oder – wenn möglich – gerade bei kleineren Formularen den Code selbst aufzusetzen.

Da es im Internet kaum Lösungsansätze zu finden gab, hoffen wir, dass wir vielleicht einigen von euch hiermit helfen können.

Hinweis vom 13.07.2014:
websplash bietet nun auch eigenes Hosting an. Dabei ist das Paket optimal auf WordPress abgestimmt. Jetzt unverbindlich kontaktieren.

Kommentare

  1. @ Dieses Problem wurde bislang nur in Zusammenhang mit einem Hosting bei 1und1beobachtet, die genaue Fehlerursache konnten wir aber nicht finden.

    Kann die Ursache sagen, denn ich habe/hatte das gleiche Problem bei 1 und 1: Wenn die Website zu umfangreich wird, dann soll man das Hosting-Paket unbedingt erweitern/wechseln, da die Ressourcen nicht mehr ausreichen!
    Da kann man PlugIns deaktivieren, deinstallieren was man will…das Problem bleibt immer das gleiche, solange man das Hosting-Paket nicht ändert!
    Lieber Gruß
    Lorie

    • websplash meint:

      Besten Dank für die Rückmeldung. Ich selbst nutze den Anbieter auch nicht und empfehle auch meinen Kunden lieber Alfahosting. 1und1 macht da regelmäßig Probleme, sobald das memory_limit zu hoch wird.

      • Bitte gerne!
        1 und 1 ist normalerweise echt toll, aber da sind sie ein wenig gemein-sie könnten einen ruhig darauf aufmerksam machen, dass das Limit erreicht ist. Dieses Problem hat mich leider viele Besucher gekostet, was NICHT lustig ist!!
        Wer besucht schon gerne eine Seite, die einmal schnell, und einmal langsam geht?
        Da springt dir doch jeder ab!
        Im übrigen sollte man mit den PlugIns bei WordPress sowieso vorsichtig sein, denn manche können die komplette Seite auf Fatal-Error setzen! Vor allem, wenn die von mir gefürchteten Updates kommen…da hab ich einen Horror davor!!
        Immer eine Spiegel-Seite anlegen, und die Plugins zuerst testen.

        Lg Lorie

        • websplash meint:

          Normalerweise wird das memory_limit auch angezeigt, da das WordPress Skript in diesem Fall aber erst nach Klick auf einen Button ausgeführt wird, ist der Prozess im Hintergrund und bricht dann ab. Daher keine genaue Meldung (es erscheint nach mehreren Sekunden ja eine Fehlermeldung, nur nicht mit Ursache. Da kann auch 1und1 nichts machen).

          Plugins sind immer mit Vorsicht zu genießen, man sollte entweder selbst welche schreiben oder nur sehr gut bewertete Plugins verwenden. Eine Kopie der Seite ist immer sehr sinnvoll. Diese „Fatal-Error“ Geschichten können meist ganz leicht behoben werden, jedoch muss man sich dafür mit u.a. PHP gut auskennen. Deshalb Plugins am besten immer erst dann updaten, wenn auf der WordPress Seite genügen Infos über das Funktionieren der Plugins mit der neuesten WP-Version zu finden sind.

  2. Ich habe genau das gleiche Problem und mir die Finger wund gesucht. Ich finde mehr und mehr Beschwerden darüber und keiner hat eine Lösung.

    Jeder verwendet andere Plugins und daran scheint es nicht zu liegen. Ich bin auf einem recht großen Strato-Hosting-Paket mit 128 MByte RAM und mein WP nimmt gerade mal 28 MByte in Anspruch.

    Auf dem selben Hosting-Paket läuft noch eine andere WP-Installation (älter). Die hat das Problem nicht und ist sehr schnell. Dass die ganze Seite blockiert ist, ist bei mir ebenfalls der Fall. Ob das von einem Außenstehenden auch so wahrgenommen wird, kann ich allerdings nicht sagen.

    • websplash meint:

      Hallo Jürgen, auf meinem Server habe ich das Problem noch nicht reproduzieren können, ich schaue aber gerne mal kostenfrei bei dir auf den Server und versuche eine Lösung zu finden, um diese dann allen mitteilen zu können. Viele Grüße

  3. Martina meint:

    und woran lage es dann?
    Die Frage wurde mir jetzt nämlich auch gestellt.

Ihre Meinung ist uns wichtig

*

Ausgezeichnet.org